Tools, FAQ, Tutorials:
"byfn.sh up" Error - Container Name in Use
Why am I getting the "Cannot create container for service peer0.org1.example.com: b'Conflict." error when running "byfn.sh up" to start up the BYFN Network?
✍: FYIcenter.com
You are getting "Cannot create container for service
peer0.org1.example.com: b'Conflict." error when
running the "byfn.sh up" command,
because there container name "peer0.org1.example.com" already exists
on the Docker Engine.
This error condition happens frequently on your local test environment, because many test networks are using the same container name "peer0.org1.example.com".
To resolve the issue, you can stop and remove the offending container:
$ docker container ls -a | grep peer0 ... hyperledger/fabric-peer:1.4 "peer node start" peer0.org1.example.com $ docker container stop "peer0.org1.example.com" peer0.org1.example.com $ docker container rm "peer0.org1.example.com" peer0.org1.example.com
Repeat the same steps to remove other containers.
⇒ BYFN Containers Running on Docker
⇐ "byfn.sh down" - Shut Down BYFN Network
2020-05-05, ∼2081🔥, 0💬
Popular Posts:
What Happens If One Row Has Missing Columns? What happens if one row has missing columns? Most brows...
How to access Query String parameters from "context.Request.Url.Que ry"object in Azure API Policy? Q...
How to use the "set-body" Policy Statement for an Azure API service operation? The "set-body" Policy...
How to use the "Ctrl-p Ctrl-q" sequence to detach console from the TTY terminal of container's runni...
How to use the "@{...}" expression block in Azure API Policy? The "@{...}" expression block in Azure...