Warning on Incompatible "npm" Version


Why I am getting the Incompatible "npm" Version warning with installating Hyplerledger Composer CLI on Ubuntu?

✍: FYIcenter.com


You may get the Incompatible "npm" Version warning, if you install Hyplerledger Composer CLI with the "@0.20" version option:

$ sudo npm install -g composer-cli@0.20

WARN engine composer-cli@0.20.8: wanted: {"node":">=8","npm":">=5"} 
 (current: {"node":"8.10.0","npm":"3.5.2"})

This is because Hyperledger 0.20.8 requires npm 5.0 or higher. But only npm 3.5.2 is installed on the system.


⇒ Issue to Install "npm 5.x" on Ubuntu 18

⇐ Start/Stop Hyperledger Fabric Dev Environment

⇑ Install Hyplerledger Composer Environment

⇑⇑ Hyperledger Composer Tutorials

2021-04-04, 913🔥, 0💬